Using JgraphT using Pyhton 3.8.3 and ubuntu 14.04

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Using JgraphT using Pyhton 3.8.3 and ubuntu 14.04

Muhsin Atto
Hi Sir,

I would like to use JgraphT package using Python 3.8.3 and Ubuntu 14.04
When I am typing this: pip install jgrapht

It says your version must be greater than 3.6. Given error is attached in this email. But my python version is the blast one (3.8.3).

When I'm typing this: python --version
This is give:
dlo@Dlo:~$ python --version
Python 3.8.3


Could you please help me how to install JgraphT into my Ubuntu.

Regards
Muhsin


_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users

Error.png (201K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Using JgraphT using Pyhton 3.8.3 and ubuntu 14.04

Joris Kinable-2
Please submit an issue here:

On Tue, Jun 30, 2020 at 4:59 PM Muhsin Atto <[hidden email]> wrote:
Hi Sir,

I would like to use JgraphT package using Python 3.8.3 and Ubuntu 14.04
When I am typing this: pip install jgrapht

It says your version must be greater than 3.6. Given error is attached in this email. But my python version is the blast one (3.8.3).

When I'm typing this: python --version
This is give:
dlo@Dlo:~$ python --version
Python 3.8.3


Could you please help me how to install JgraphT into my Ubuntu.

Regards
Muhsin
_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users


_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users
Reply | Threaded
Open this post in threaded view
|

Re: Using JgraphT using Pyhton 3.8.3 and ubuntu 14.04

d-michail
In reply to this post by Muhsin Atto
You need to follow the instructions here 


Pip version must be >= 19.0, otherwise it tries to build from source. 
Use `pip install --upgrade pip` before installing


On Wed, Jul 1, 2020 at 2:59 AM Muhsin Atto <[hidden email]> wrote:
Hi Sir,

I would like to use JgraphT package using Python 3.8.3 and Ubuntu 14.04
When I am typing this: pip install jgrapht

It says your version must be greater than 3.6. Given error is attached in this email. But my python version is the blast one (3.8.3).

When I'm typing this: python --version
This is give:
dlo@Dlo:~$ python --version
Python 3.8.3


Could you please help me how to install JgraphT into my Ubuntu.

Regards
Muhsin
_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users


_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users
Reply | Threaded
Open this post in threaded view
|

Re: Using JgraphT using Pyhton 3.8.3 and ubuntu 14.04

d-michail
Moreover, you are using an old ubuntu system which has python 2 as the default. 
Make sure that you use python3 and pip3.



On Wed, Jul 1, 2020 at 12:30 PM Dimitrios Michail <[hidden email]> wrote:
You need to follow the instructions here 


Pip version must be >= 19.0, otherwise it tries to build from source. 
Use `pip install --upgrade pip` before installing


On Wed, Jul 1, 2020 at 2:59 AM Muhsin Atto <[hidden email]> wrote:
Hi Sir,

I would like to use JgraphT package using Python 3.8.3 and Ubuntu 14.04
When I am typing this: pip install jgrapht

It says your version must be greater than 3.6. Given error is attached in this email. But my python version is the blast one (3.8.3).

When I'm typing this: python --version
This is give:
dlo@Dlo:~$ python --version
Python 3.8.3


Could you please help me how to install JgraphT into my Ubuntu.

Regards
Muhsin
_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users


_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users
Reply | Threaded
Open this post in threaded view
|

Re: Using JgraphT using Pyhton 3.8.3 and ubuntu 14.04

d-michail
Just for future reference, the following post 

contains answers on how to use pip with different versions of python. 

On Wed, Jul 1, 2020 at 12:50 PM Dimitrios Michail <[hidden email]> wrote:
Moreover, you are using an old ubuntu system which has python 2 as the default. 
Make sure that you use python3 and pip3.



On Wed, Jul 1, 2020 at 12:30 PM Dimitrios Michail <[hidden email]> wrote:
You need to follow the instructions here 


Pip version must be >= 19.0, otherwise it tries to build from source. 
Use `pip install --upgrade pip` before installing


On Wed, Jul 1, 2020 at 2:59 AM Muhsin Atto <[hidden email]> wrote:
Hi Sir,

I would like to use JgraphT package using Python 3.8.3 and Ubuntu 14.04
When I am typing this: pip install jgrapht

It says your version must be greater than 3.6. Given error is attached in this email. But my python version is the blast one (3.8.3).

When I'm typing this: python --version
This is give:
dlo@Dlo:~$ python --version
Python 3.8.3


Could you please help me how to install JgraphT into my Ubuntu.

Regards
Muhsin
_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users


_______________________________________________
jgrapht-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgrapht-users